网站错误提示“Error establishing a Redis connection”怎么办?

WordPress建站使用缓存软件之后,经常会出现“Error establishing a Redis connection”的提示,如图:

网站错误提示“Error establishing a Redis connection”怎么办?

去宝塔面板查看后发现,是因为MongoDB或者Redis插件被关闭,你需要手动重启插件才行。

网站错误提示“Error establishing a Redis connection”怎么办?

我也没找到具体原因,想着应该是数据过大(70w条帖子),也有可能是我的设置有问题或者wp程序自身对大数据的处理不够好,所以我想了办法,避免晚上网站宕机影响网站流量,所以就做了这个自动脚本。

代码语言:javascript
复制
#!/bin/bash

# 检测 Redis 是否在运行
redis_status=$(systemctl is-active redis.service)

if [ "$redis_status" != "active" ]; then
    echo "Redis is not running. Restarting Redis..."
    systemctl start redis.service
    echo "Redis restarted."
fi

# 检测网站是否可访问
website_url="http://xiu.xzwidea.cn"  # 替换为你要检测的网站 URL
http_status=$(curl -s -o /dev/null -w "%{http_code}" $website_url)

if [ "$http_status" != "200" ]; then
    echo "Website is not accessible. Restarting Redis..."
    systemctl restart redis.service
    echo "Redis restarted."
fi

设置计划任务,把这个Shell脚本添加到计划任务中,设置每一分钟检测一次:

网站错误提示“Error establishing a Redis connection”怎么办?

然后你会发现基本上出了问题就会自动处理了!

关于网站错误提示“Error establishing a Redis connection”怎么办?的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2024年7月31日 上午11:47
下一篇 2024年7月31日 下午12:00

相关推荐

  • 宝塔面板设置又拍云备份出现“API资料效验失败,请核实“提示的解决办法以及原因

    今天在宝塔面板设置备份网站,由于又拍云是有免费备份的存储空间的,所有就用又拍云备份网站,但是设置的时候出现了提示:“API资料效验失败,请核实“(如下图),倒腾了半天,后来找出了原因!下面博主来说说宝塔面板设置又拍云备份出现“API资料效验失败,请核实“提示的解决办法以及原因。 原因1:如果你是外网服务器,请关闭宝塔面板防火墙里面的禁止“国外访问”。 原因2…

    2021年8月12日
    1.1K
  • WordPress网站优化插件youpzt-optimizer,给网站提速70%

    很多用WordPress程序的站长朋友觉得现在wordpress越来越慢了!排除主机配置因素不谈,还有不少原因影响网站加载速度: 谷歌被墙,谷歌字体长时间加载不下来; Gravatar头像加载缓慢,或加载失败; 使用代码书写不规范或代码质量差的主题或者插件; 加载了没有必要的文件或垃圾数据; WordPress程序版本检查更新 …… 所以就制作了一个网站优化…

    2023年1月4日
    226
  • WP-CDN-Yes WordPress 自动清除CDN插件

    插件概述 WP-CDN-Yes是我开发的一款WordPress插件,其主功能是在启用全站CDN的情况下,自动清除CDN节点缓存。 对网站进行全站CDN缓存能有效优化网站部署在低配置服务器的访问速度,同时也带来了一些繁琐问题,比如每次发布文章都要手动刷新CDN缓存,此插件就是为解决这些麻烦而诞生的。 插件下载 当前最新版本:2.1.0 直接在WP后台搜索WP-…

    2022年4月13日 • 建站知识
    486
  • HTTP状态码常见的网站错误代码大全

    这里收集常见的错误代码。 不常见的我就不写了。 一些常见的状态码为: 200 – 服务器成功返回网页 404 – 请求的网页不存在 503 – 服务不可用 详细分解: 206 (部分内容) 服务器成功处理了部分 GET 请求。 301 (永久移动) 请求的网页已永久移动到新位置。服务器返回此响应(对 GET 或 HEAD …

    2021年11月17日
    599
  • WordPress安装更新主题、插件时需要FTP的解决办法

    由于今天换服务器了,wordpress搬家了一下,结果更新插件的时候,出现如图现象:或者有时候,我们在安装主题的时候,也会报同样的错误,如下图: 解决方法 不管是上面任意一种错误,还是有类似的 FTP 或 SFTP 错误,其实,我们都可以解决。具体的解决操作步骤如下: 第一步:连接FTP或服务器,再网站根目录,找到wp-config.php 配置文件。 在代…

    2023年5月27日
    597