Nginx常用屏蔽规则,让网站更安全

nginx-block-rules.jpg

 

引言

Ng­inx (en­gine x) 是一个高性能的 HTTP 和反向代理服务,目前很大一部分网站均使用了 Ng­inx 作为 WEB 服务器,Ng­inx 虽然非常强大,但默认情况下并不能阻挡恶意访问,这里有一份常用的 Ng­inx 屏蔽规则,希望对你有所帮助。

在开始之前,希望您已经熟悉 Ng­inx 常用命令(如停止、重启等操作)及排查 ng­inx 错误日志,以免出现问题不知所措。如无特殊注明,以下的命令均添加到 server 段内,修改 nginx 配置之前务必做好备份,修改完毕后需要重载一次 nginx,否则不会生效。

防止文件被下载

比如将网站数据库导出到站点根目录进行备份,很有可能也会被别人下载,从而导致数据丢失的风险。以下规则可以防止一些常规的文件被下载,可根据实际情况增减。

location ~ \.(zip|rar|sql|bak|gz|7z)$ {
  return 444;
}

屏蔽非常见蜘蛛(爬虫)

如果经常分析网站日志你会发现,一些奇怪的 UA 总是频繁的来访问网站,而这些 UA 对网站收录毫无意义,反而增加服务器压力,可以直接将其屏蔽。

if ($http_user_agent ~* (SemrushBot|python|MJ12bot|AhrefsBot|AhrefsBot|hubspot|opensiteexplorer|leiki|webmeup)) {
     return 444;
}

禁止某个目录执行脚本

比如网站上传目录,通常存放的都是静态文件,如果因程序验证不严谨被上传木马程序,导致网站被黑。以下规则请根据自身情况改为您自己的目录,需要禁止的脚本后缀也可以自行添加。

#uploads|templets|data 这些目录禁止执行PHP
location ~* ^/(uploads|templets|data)/.*.(php|php5)$ {
    return 444;
}

屏蔽某个IP或IP段

如果网站被恶意灌水或 CC 攻击,可从网站日志中分析特征 IP,将其 IP 或 IP 段进行屏蔽。

#屏蔽192.168.5.23这个IP
deny 192.168.5.23;
#屏蔽192.168.5.* 这个段
deny 192.168.5.0/24;

其它说明

再次强调,修改 nginx 配置之前务必做好备份,修改完毕后需要重载一次 nginx,否则不会生效。

上面大部分规则返回 444 状态码而不是 403,因为 444 状态码在 ng­inx 中有特殊含义。ng­inx 的 444 状态是直接由服务器中断连接,不会向客户端再返回任何消息,比返回 403 更加暴力。若有不足还请补充和指正。

关于Nginx常用屏蔽规则,让网站更安全的相关内容;如有侵权,请联系老文删除。

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年8月25日 上午12:30
下一篇 2021年8月25日 上午12:52

相关推荐

  • 安装zblog提示“创建c_option.php失败”的原因和解决办法

    有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图: 本文来说明下这个问题的原因和解决办法。 问题产生的原因: c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。 所以这个问题的原因就是你的主机权限不…

    2021年11月18日
    626
  • WordPress解决文章ID不连续的问题

    WordPress文章ID不连续题是一个很正常的现象,不是你的博客出了问题,而是WordPress系统默认的,不用在意忽略它。 但是对于有着轻微强迫症,追求完美的朋友来说,这的确很让人讨厌。 在WordPress后台并没有直接的提供关闭这个功能的选项,那么该如何解决文章ID不连续的问题呢?今天就比格给大家讲讲如何把这个功能完完全全的隐蔽掉。 找到当前主题目录…

    2021年11月2日
    502
  • 宝塔面板mysql进程守护shell脚本(数据库关闭后自动重启)

    我们使用宝塔面板搭建网站时,Mysql数据库有时会意外停止,这时候我们只能登录服务器进行手动重启Mysql。那么怎么设置监控Mysql的运行情况,当数据库进程停止时,自动重启Mysql数据库呢?其实我们可以通过添加计划任务(Shell脚本)的方式来实现。具体操作方法如下: 登陆宝塔面板后台 – 计划任务。任务类型:Shell脚本 任务名称:Mysql进程守护…

    2024年6月21日
    366
  • WordPress 使用 ElasticSearch 搜索方法

    众所周知,ElasticSearch (下文简称ES)是一个相当牛逼的全文搜索引擎,对接它以后,WordPress 的搜索也能变得更智能更优秀,此文章将介绍如果用最简单的方法部署一个 ES 服务器并对接到 WordPress 网站。 主注意:ES 是个吃性能的怪兽,不太建议内存<4G的服务器安装之。 一、安装 Podman 容器管理器 为了便于维护以及…

    2022年4月13日
    1.0K
  • 如何防止网站被挂木马

    今天有一个网站被挂了木马,还好备份了网站文件,还原了备份文件之后,网站才得以正常运行,那么如何防止网站被挂马是每一个网站管理者所要必须面对的,在这里我们给大家提供七招来屏蔽网站被挂马的主要途径,解决了这个问题也就解决了网站的安全问题。 第一招,黑客一般给你放马,都是通过工具来扫描你的程序漏洞,在你的网站上线之前,你就自己先用他们常用的工具自己扫描一下程序的安…

    2021年8月17日
    565