Nginx常用屏蔽规则,让网站更安全

nginx-block-rules.jpg

 

引言

Ng­inx (en­gine x) 是一个高性能的 HTTP 和反向代理服务,目前很大一部分网站均使用了 Ng­inx 作为 WEB 服务器,Ng­inx 虽然非常强大,但默认情况下并不能阻挡恶意访问,这里有一份常用的 Ng­inx 屏蔽规则,希望对你有所帮助。

在开始之前,希望您已经熟悉 Ng­inx 常用命令(如停止、重启等操作)及排查 ng­inx 错误日志,以免出现问题不知所措。如无特殊注明,以下的命令均添加到 server 段内,修改 nginx 配置之前务必做好备份,修改完毕后需要重载一次 nginx,否则不会生效。

防止文件被下载

比如将网站数据库导出到站点根目录进行备份,很有可能也会被别人下载,从而导致数据丢失的风险。以下规则可以防止一些常规的文件被下载,可根据实际情况增减。

location ~ \.(zip|rar|sql|bak|gz|7z)$ {
  return 444;
}

屏蔽非常见蜘蛛(爬虫)

如果经常分析网站日志你会发现,一些奇怪的 UA 总是频繁的来访问网站,而这些 UA 对网站收录毫无意义,反而增加服务器压力,可以直接将其屏蔽。

if ($http_user_agent ~* (SemrushBot|python|MJ12bot|AhrefsBot|AhrefsBot|hubspot|opensiteexplorer|leiki|webmeup)) {
     return 444;
}

禁止某个目录执行脚本

比如网站上传目录,通常存放的都是静态文件,如果因程序验证不严谨被上传木马程序,导致网站被黑。以下规则请根据自身情况改为您自己的目录,需要禁止的脚本后缀也可以自行添加。

#uploads|templets|data 这些目录禁止执行PHP
location ~* ^/(uploads|templets|data)/.*.(php|php5)$ {
    return 444;
}

屏蔽某个IP或IP段

如果网站被恶意灌水或 CC 攻击,可从网站日志中分析特征 IP,将其 IP 或 IP 段进行屏蔽。

#屏蔽192.168.5.23这个IP
deny 192.168.5.23;
#屏蔽192.168.5.* 这个段
deny 192.168.5.0/24;

其它说明

再次强调,修改 nginx 配置之前务必做好备份,修改完毕后需要重载一次 nginx,否则不会生效。

上面大部分规则返回 444 状态码而不是 403,因为 444 状态码在 ng­inx 中有特殊含义。ng­inx 的 444 状态是直接由服务器中断连接,不会向客户端再返回任何消息,比返回 403 更加暴力。若有不足还请补充和指正。

关于Nginx常用屏蔽规则,让网站更安全的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年8月25日 上午12:30
下一篇 2021年8月25日 上午12:52

相关推荐

  • 没有备案的国际域名申请QQ互联的方法

    没有备案的国际域名申请QQ互联的方法 目前亲测 .com后缀域名都可以,其他国际域名也可以试试,正常是可以的。 QQ互联官网 https://connect.qq.com/index.html 1、先去QQ互联申请网站应用 网站北岸号填写:【海外网站/国际网站】 非国内网站申请QQ互联登陆(国际域名) 2、下载表格,填好表格 给腾讯发送申请邮件 参考:htt…

    2021年10月9日
    668
  • 宝塔面板创建的ftp登陆无法连接解决办法?

    宝塔面板创建的ftp登陆无法连接解决办法? 一:问题描述: 阿里云服务器安装了宝塔linux面板,创建了ftp,利用xftp选择ftp协议连接不上问题? 二:解决方法: 登陆阿里云服务器,在阿里云服务器安全组中放行端口21,并且被动端口(39000 – 40000)也需要处于放行状态,进入宝塔Linux面板中的软件管理,找到Pure-Ftpd 1…

    2021年9月21日
    784
  • zblog后台的应用中心登录不了 提示错误怎么办?

    最近突然有些用户反应自己的zblog网站后台里面的应用中心登录不了,提示错误。 我们先不谈错误,先来谈下后台应用中心登录的正确步骤: 第一步:打开后台–点击应用中心–点击登录应用商城,如下图所示: 第二步:应用中心登录需要你输入令牌,点击上图的“点击获取账户登录令牌”跳转到“ https://uc.zblogcn.com/user/s…

    2021年11月18日
    799
  • 百度快速收录权益如何获取与使用说明

    加入百度站长平台的站长应该知道,百度有个普通收录和快速收录,其中普通收录百度没有控制权限,但是快速收录百度却需要获取“快速收录权益”。那么我们要怎么样获取快速收录权益呢? 1. 什么是快速收录? 开发者可通过快速收录工具,向百度搜索主动提交站点新增的高时效性资源,缩短爬虫发现网站链接的时间,一般情况下48小时内即可实现收录。 需要注意的是,快速收录仅限于提交…

    2021年8月12日
    1.0K
  • 安装zblog提示“创建c_option.php失败”的原因和解决办法

    有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图: 本文来说明下这个问题的原因和解决办法。 问题产生的原因: c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。 所以这个问题的原因就是你的主机权限不…

    2021年11月18日
    626