Nginx常用屏蔽规则,让网站更安全

nginx-block-rules.jpg

 

引言

Ng­inx (en­gine x) 是一个高性能的 HTTP 和反向代理服务,目前很大一部分网站均使用了 Ng­inx 作为 WEB 服务器,Ng­inx 虽然非常强大,但默认情况下并不能阻挡恶意访问,这里有一份常用的 Ng­inx 屏蔽规则,希望对你有所帮助。

在开始之前,希望您已经熟悉 Ng­inx 常用命令(如停止、重启等操作)及排查 ng­inx 错误日志,以免出现问题不知所措。如无特殊注明,以下的命令均添加到 server 段内,修改 nginx 配置之前务必做好备份,修改完毕后需要重载一次 nginx,否则不会生效。

防止文件被下载

比如将网站数据库导出到站点根目录进行备份,很有可能也会被别人下载,从而导致数据丢失的风险。以下规则可以防止一些常规的文件被下载,可根据实际情况增减。

location ~ \.(zip|rar|sql|bak|gz|7z)$ {
  return 444;
}

屏蔽非常见蜘蛛(爬虫)

如果经常分析网站日志你会发现,一些奇怪的 UA 总是频繁的来访问网站,而这些 UA 对网站收录毫无意义,反而增加服务器压力,可以直接将其屏蔽。

if ($http_user_agent ~* (SemrushBot|python|MJ12bot|AhrefsBot|AhrefsBot|hubspot|opensiteexplorer|leiki|webmeup)) {
     return 444;
}

禁止某个目录执行脚本

比如网站上传目录,通常存放的都是静态文件,如果因程序验证不严谨被上传木马程序,导致网站被黑。以下规则请根据自身情况改为您自己的目录,需要禁止的脚本后缀也可以自行添加。

#uploads|templets|data 这些目录禁止执行PHP
location ~* ^/(uploads|templets|data)/.*.(php|php5)$ {
    return 444;
}

屏蔽某个IP或IP段

如果网站被恶意灌水或 CC 攻击,可从网站日志中分析特征 IP,将其 IP 或 IP 段进行屏蔽。

#屏蔽192.168.5.23这个IP
deny 192.168.5.23;
#屏蔽192.168.5.* 这个段
deny 192.168.5.0/24;

其它说明

再次强调,修改 nginx 配置之前务必做好备份,修改完毕后需要重载一次 nginx,否则不会生效。

上面大部分规则返回 444 状态码而不是 403,因为 444 状态码在 ng­inx 中有特殊含义。ng­inx 的 444 状态是直接由服务器中断连接,不会向客户端再返回任何消息,比返回 403 更加暴力。若有不足还请补充和指正。

关于Nginx常用屏蔽规则,让网站更安全的相关内容;如有侵权,请联系老文删除。

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年8月25日 上午12:30
下一篇 2021年8月25日 上午12:52

相关推荐

  • 详解WordPress主题三种安装方式

    给大家介绍关于WordPress安装主题的三种方式,希望对需要的朋友有所帮助!相比于其他CMS,WordPress最大的特色就是它可以让你更换主题,无需代码就能定制网站外观,那么如何为你的站点安装WordPress主题呢,在本文中我们来分享几个常用方法 通过WordPress后台安装主题 WordPress 使用非常方便,很重要一点就是它大部分功能可以在后台…

    2022年2月12日 建站知识
    372
  • WordPress中不用的图片怎么删除

    默认情况下,WordPress 会将你上传的图片自动生成几种不同大小的缩略图,但是有些WordPress主题根本就不会调用这些缩略图,它们就成了多余的啦。那么,如何才能快速删除这些已经生成的缩略图呢?建议试试DNUI(Delete not used image)插件。 DNUI Delete not used image介绍及使用方法 Delete not …

    2023年1月4日
    218
  • wordpress标题自动生成英文别名(拼音)美化网址

    使用wordpress程序建站的朋友很多,因为wp的易用性和可扩展性非常强大,也促使很多朋友开发了不同的主题和插件来实现各种网站功能。比如wordpress默认在编辑文章时的网址标题含有中文字符,这样会使网址不够美观。所以我们就需要手动把网址中的汉字改为拼音或者英文,那么有没有办法让wordpress标题自动生成英文别名(拼音)呢? 有的。wordpress…

    2021年8月12日
    881
  • 腾讯云轻量应用服务器云硬盘挂载教程(挂载释放后才能用)

    前言:之前作者买的腾讯云的轻量应用服务器无忧套餐,无忧套餐顾名思义,使用无忧续费同价,良心云名不虚传,但是我买的是低配的硬盘只有50G,考虑到目前的数据增长情况,这个硬盘大小是不够的,比较好的是在用户的呼声下,轻量的产品经理安排上线了轻量的云硬盘,解决了容量不够这一个大问题,必须点赞。下面大家就跟着我的思路来进行硬盘挂载吧。 首先你要在腾讯云控制台,把硬盘挂…

    2022年11月12日
    273
  • 网站错误提示“Error establishing a Redis connection”怎么办?

    WordPress建站使用缓存软件之后,经常会出现“Error establishing a Redis connection”的提示,如图: 去宝塔面板查看后发现,是因为MongoDB或者Redis插件被关闭,你需要手动重启插件才行。 我也没找到具体原因,想着应该是数据过大(70w条帖子),也有可能是我的设置有问题或者wp程序自身对大数据的处理不够好,所以…

    2024年7月31日
    589