安装zblog提示“创建c_option.php失败”的原因和解决办法

有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图:

安装zblog提示“创建c option.php失败”的原因和解决办法 zblog安装 c option.php zblogphp教程 第1张

本文来说明下这个问题的原因和解决办法。

问题产生的原因:

c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。

所以这个问题的原因就是你的主机权限不够造成的。

问题的解决办法:

第一种:可以按照错误页面的提示,直接现在本地创建一个“c_option.php”文件,然后打开这个文件,把下面的代码复制粘贴到文件里面然后保存。最后上传到“根目录/zb_users/”文件夹里面即可。

PS:此方法治标不治本,你在后续的使用zblog的过程中还是会遇到因为权限不足导致的各种问题的。所以强烈推荐下面的方法。


第二种:将你的主机权限设置为“777”!

这种方法说起来简单,但是很多小白用户根本不知道从何下手…

因为每个人主机的环境都是不一样的,有的是windows+iis;有的是linux+Apache;有的是Linux+nginx;每一种环境下的设置方法是不一样的。所以请先确定你的环境是哪一种,然后用“环境名称”+“权限设置”为关键词去百度搜索下即可找到对应教程。

关于安装zblog提示“创建c_option.php失败”的原因和解决办法的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年11月18日 下午9:10
下一篇 2021年12月11日 下午9:07

相关推荐

  • zblog提示“授权文件非法“的终极解决办法

    最近一段时间有很多的用户遇到了这个“授权文件非法”的提示,这是由于zblog的应用中心插件调整了规则导致的。 之前本站写过一篇“zblog报错“授权文件非法”的错误原因和解决办法”的文章,但是还是有用户反应按照教程操作了之后还是提示“授权文件非法”。 这个时候请用本文所介绍的终极解决办法,一次解决“授权文件非法“问题: 1、打开你网站后台–插件管…

    2021年11月18日
    676
  • WP-CDN-Yes WordPress 自动清除CDN插件

    插件概述 WP-CDN-Yes是我开发的一款WordPress插件,其主功能是在启用全站CDN的情况下,自动清除CDN节点缓存。 对网站进行全站CDN缓存能有效优化网站部署在低配置服务器的访问速度,同时也带来了一些繁琐问题,比如每次发布文章都要手动刷新CDN缓存,此插件就是为解决这些麻烦而诞生的。 插件下载 当前最新版本:2.1.0 直接在WP后台搜索WP-…

    2022年4月13日 • 建站知识
    486
  • 做网站是使用Nginx还是Apache

    有关 Nginx 和 Apache 的介绍我就不做赘述了,大家自行百度、谷歌一下就可以了解了,废话不多说了,直奔主题。 1、作为 Web 服务器:相比 Apache,Nginx 使用更少的资源,支持更多的并发连接,体现更高的效率,这点使 Nginx 尤其受到虚拟主机提供商的欢迎。 在高连接并发的情况下,Nginx 是 Apache 服务器不错的替代品;Ngi…

    2021年11月17日
    392
  • WordPress网站优化插件youpzt-optimizer,给网站提速70%

    很多用WordPress程序的站长朋友觉得现在wordpress越来越慢了!排除主机配置因素不谈,还有不少原因影响网站加载速度: 谷歌被墙,谷歌字体长时间加载不下来; Gravatar头像加载缓慢,或加载失败; 使用代码书写不规范或代码质量差的主题或者插件; 加载了没有必要的文件或垃圾数据; WordPress程序版本检查更新 …… 所以就制作了一个网站优化…

    2023年1月4日
    226
  • Discuz论坛网站首页窄屏自定义宽度修改图文教程

    Discuz论坛管理中心默认有窄屏和宽屏的选择,窄屏默认是960px宽度,很多论坛为了页面美观,基本都是1200px的宽度,如何修改DZ论坛首页窄屏宽度大小的呢? 1、在网站根目录中依次打开文件 /template/default/common/common.css 2、直接在文件中快速查找960(文本编辑器中查找快捷键是ctrl+F5)会出现3处,将这3处…

    2024年7月30日 • 建站知识
    192