安装zblog提示“创建c_option.php失败”的原因和解决办法

有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图:

安装zblog提示“创建c option.php失败”的原因和解决办法 zblog安装 c option.php zblogphp教程 第1张

本文来说明下这个问题的原因和解决办法。

问题产生的原因:

c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。

所以这个问题的原因就是你的主机权限不够造成的。

问题的解决办法:

第一种:可以按照错误页面的提示,直接现在本地创建一个“c_option.php”文件,然后打开这个文件,把下面的代码复制粘贴到文件里面然后保存。最后上传到“根目录/zb_users/”文件夹里面即可。

PS:此方法治标不治本,你在后续的使用zblog的过程中还是会遇到因为权限不足导致的各种问题的。所以强烈推荐下面的方法。


第二种:将你的主机权限设置为“777”!

这种方法说起来简单,但是很多小白用户根本不知道从何下手…

因为每个人主机的环境都是不一样的,有的是windows+iis;有的是linux+Apache;有的是Linux+nginx;每一种环境下的设置方法是不一样的。所以请先确定你的环境是哪一种,然后用“环境名称”+“权限设置”为关键词去百度搜索下即可找到对应教程。

关于安装zblog提示“创建c_option.php失败”的原因和解决办法的相关内容;如有侵权,请联系老文删除。

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年11月18日 下午9:10
下一篇 2021年12月11日 下午9:07

相关推荐

  • 织梦DedeCMS用来建立博客网站需要授权吗?有版权问题吗

    织梦DedeCMS内容管理系统以简单、实用、开源而闻名,而织梦DedeCMS分为两个版本:一是免费版,适合很多个人站长用来建立各种非营利类型网站;二是商业授权版,适合政府单位、教育机构、协会团体、企业、以营利为目的的站点使用。这两个版本的版权说明对比如下表所示: 截图来自DedeCMS官网 而且根据《DedeCMS最终用户授权协议》许可的权利之一就是“您可以…

    2021年9月27日
    460
  • 宝塔面板安装指定历史版本教程

    使用宝塔官方一键命令,直接搭建出来的是最新版的宝塔。但是,很多时候我们需要使用低版本的,这个时候就没有办法直接使用一键命令来搭建了。下面就讲讲怎么安装指定历史版本宝塔面板。 一、版本合集(2022年1月6日更新) http://download.bt.cn/install/update/LinuxPanel-1.0.3.zip http://download…

    2022年5月16日
    863
  • 批量替换WordPress文章内容中的文字

    批量替换WordPress文章中的文字 如果准备替换修改散布在大量WordPress文章中的相同文字,手动编辑文章修改工作量大,可以用下面的代码实现批量替换,会用到WordPress的操作数据常量$wpdb修改数据库,不需要登录数据库操作。 将代码添加到当前主题函数模板functions.php的最后: 1 2global $wpdb; $wpdb->…

    2021年8月12日
    1.2K
  • WordPress网站常用的SEO插件和工具介绍

    WordPress是款功能强大的内容管理系统,拥有诸多的插件和主题模板,我们可用它来创建外贸网站,网站成功上线后需要进行日常优化,那么WordPress SEO插件和工具有哪些呢?本文为大家分享几款WordPress网站常用的SEO插件及相关工具。 外贸网站一般用户访问量大,选择合适的主机服务器是网站SEO的重要前提,所以我们可以优先选择带宽资源充足、稳定性…

    2023年1月9日
    208
  • 腾讯轻量服务器挂载云硬盘的方法

    操作步骤 使用控制台挂载云硬盘 登录 云硬盘控制台。 在云硬盘列表页,您可以通过以下方法挂载云硬盘: 挂载单个云硬盘:选择状态为“待挂载”的云硬盘所在行右侧的更多 > 挂载。 批量挂载云硬盘:勾选状态为“待挂载”的云硬盘,单击云硬盘列表上方的挂载进行批量挂载。 弹出“挂载到实例”窗口,进入“挂载到实例”步骤。如下图所示: 选择需挂载的实例,并参考以下信…

    2022年11月27日
    220