安装zblog提示“创建c_option.php失败”的原因和解决办法

有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图:

安装zblog提示“创建c option.php失败”的原因和解决办法 zblog安装 c option.php zblogphp教程 第1张

本文来说明下这个问题的原因和解决办法。

问题产生的原因:

c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。

所以这个问题的原因就是你的主机权限不够造成的。

问题的解决办法:

第一种:可以按照错误页面的提示,直接现在本地创建一个“c_option.php”文件,然后打开这个文件,把下面的代码复制粘贴到文件里面然后保存。最后上传到“根目录/zb_users/”文件夹里面即可。

PS:此方法治标不治本,你在后续的使用zblog的过程中还是会遇到因为权限不足导致的各种问题的。所以强烈推荐下面的方法。


第二种:将你的主机权限设置为“777”!

这种方法说起来简单,但是很多小白用户根本不知道从何下手…

因为每个人主机的环境都是不一样的,有的是windows+iis;有的是linux+Apache;有的是Linux+nginx;每一种环境下的设置方法是不一样的。所以请先确定你的环境是哪一种,然后用“环境名称”+“权限设置”为关键词去百度搜索下即可找到对应教程。

关于安装zblog提示“创建c_option.php失败”的原因和解决办法的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年11月18日 下午9:10
下一篇 2021年12月11日 下午9:07

相关推荐

  • phpMyAdmin面板提示“在服务上检测到错误”怎么办?

    如果你进phpMyAdmin面板后提示这个,且每次刷新页面无法被忽略。 并且在底部出现类似这样的提示,那你有救了! 看到这儿先不要着急,我们先了解下,为么会出现这个问题?另外,有没有发现启动phpMyAdmin的时候还有这个提示: 代码语言:javascript 复制 不兼容的PHP版本,已尝试自动切换到兼容的PHP版本,请刷新页面重试! 事实上都是因为ph…

    2024年7月31日 • 建站知识
    277
  • WordPress怎么自动发布文章

    WordPress具有定期发布文章的功能。在发布界面中,有一个按钮用于立即发布和编辑文章。单击此处可编辑发布文章的时间。 因此,我们可以设置在特定时间发布文章的时间: 为什么我们需要定期发表文章?定期发表文章有哪些优点和缺点?为什么我们需要使用WordPress的定时发帖功能?对于搜索引擎和用户体验来说,在固定时间发布文章是一种非常好的体验。 因为如果我们网…

    2023年1月4日
    241
  • 使用测速脚本对 Linux 服务器进行测速

    最近又搞了个美国的服务器来学习,但是发现在国内直连速度特别慢,就想知道一下他的速度到底怎么样?在厘米大神那找了个综合测速脚本进行测速,并记录如下! 使用 root 账号登陆服务器,输入以下指令: wget -qO- bench.sh | bash 通过这个测速脚本,缙哥哥发现服务器方面,Pump Cloud 是真的不错,阿里云次之,最近买来学习Linux的那…

    2021年8月12日
    641
  • 网页出现502 bad gateway什么意思 怎么解决

    有时候小编在打开一下网页的时候,会出现502 bad gateway,往往出现了502 bad gateway的时候,网页都会出现打不开的情况。如果是遇到很急的时候网页出现502 bad gateway这个的时候都会显得十分着急。那么遇到这种情况时应该怎么解决呢?而502 bad gateway又是什么意思呢?今天小编就为各位解答一下。   一、网页出现50…

    2022年11月11日
    308
  • WordPress开启HTTPS后正文图片改为HTTPS两种方法

    WordPress 站点开启 HTTPS 后,文章中引用的图片就很有必要把 HTTP 统一改为 HTTPS,要不然会地址栏上的绿锁就会有黄色的三角,感觉是很不爽的。为了解决这个问题,我们有两种方法:一个是治标不治本的办法,就是在主题的  functions.php 文件中加入字符替换语句,这样读者在每次访问的时候会相应的把图片的 http 链接替换为 htt…

    2021年9月28日
    781