安装zblog提示“创建c_option.php失败”的原因和解决办法

有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图:

安装zblog提示“创建c option.php失败”的原因和解决办法 zblog安装 c option.php zblogphp教程 第1张

本文来说明下这个问题的原因和解决办法。

问题产生的原因:

c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。

所以这个问题的原因就是你的主机权限不够造成的。

问题的解决办法:

第一种:可以按照错误页面的提示,直接现在本地创建一个“c_option.php”文件,然后打开这个文件,把下面的代码复制粘贴到文件里面然后保存。最后上传到“根目录/zb_users/”文件夹里面即可。

PS:此方法治标不治本,你在后续的使用zblog的过程中还是会遇到因为权限不足导致的各种问题的。所以强烈推荐下面的方法。


第二种:将你的主机权限设置为“777”!

这种方法说起来简单,但是很多小白用户根本不知道从何下手…

因为每个人主机的环境都是不一样的,有的是windows+iis;有的是linux+Apache;有的是Linux+nginx;每一种环境下的设置方法是不一样的。所以请先确定你的环境是哪一种,然后用“环境名称”+“权限设置”为关键词去百度搜索下即可找到对应教程。

关于安装zblog提示“创建c_option.php失败”的原因和解决办法的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年11月18日 下午9:10
下一篇 2021年12月11日 下午9:07

相关推荐

  • 如何防止网站被挂木马

    今天有一个网站被挂了木马,还好备份了网站文件,还原了备份文件之后,网站才得以正常运行,那么如何防止网站被挂马是每一个网站管理者所要必须面对的,在这里我们给大家提供七招来屏蔽网站被挂马的主要途径,解决了这个问题也就解决了网站的安全问题。 第一招,黑客一般给你放马,都是通过工具来扫描你的程序漏洞,在你的网站上线之前,你就自己先用他们常用的工具自己扫描一下程序的安…

    2021年8月17日
    565
  • zblog的开发模式是做什么的?zblog开发模式有什么作用?

    zblog后台有一个开发模式是做什么的?zblog开发模式有什么作用呢?本文就尝试来说明下这个问题。 首先zblog的开发模式在后台–网站设置–全局设置里面如下图: 这个模式默认是关闭的。顾名思义这个模式是给开发人员使用的,一般用户不建议开启。 那么普通用户什么时候需要用到这个呢?当你的网站出现问题,某个页面出现了错误提示的时候,这个…

    2021年11月18日
    651
  • zblog提示“授权文件非法“的终极解决办法

    最近一段时间有很多的用户遇到了这个“授权文件非法”的提示,这是由于zblog的应用中心插件调整了规则导致的。 之前本站写过一篇“zblog报错“授权文件非法”的错误原因和解决办法”的文章,但是还是有用户反应按照教程操作了之后还是提示“授权文件非法”。 这个时候请用本文所介绍的终极解决办法,一次解决“授权文件非法“问题: 1、打开你网站后台–插件管…

    2021年11月18日
    675
  • 宝塔面板无法下载打包大文件怎么办?

    我们可能会遇到在宝塔面板打包了文件后,下载直接显示失败且面板直接强退的情况。 下载报错提示 咱们在下载服务器大文件的时候经常遇到这样的问题,所以有些老师傅会告诉我们去升级宽带后再进行下载操作,事实上我们可以使用外链分享下载,如下图: 外链分享 使用该功能生成的链接不受服务器影响,下载速度也会快很多。

    2024年7月31日
    319
  • zblog博客无法上传附件/上传图片失败怎么办?

    zblog论坛里面经常有网友在问“zblog无法上传附件怎么办?”或者“zblog无法上传图片怎么办?”。老文笔记尝试为大家归类几种原因。 1、上传的图片或者附件太大了超出了限制。 解决办法:后台–网站设置–全局设置–允许上传文件的大小(单位MB)。将允许上传文件的大小设置大一些。 2、主机权限不足或者有限制。 解决办法:…

    2022年11月10日
    375