安装zblog提示“创建c_option.php失败”的原因和解决办法

有zblog用户反应在安装zblog的最后一步时提示“创建c_option.php失败”,如下图:

安装zblog提示“创建c option.php失败”的原因和解决办法 zblog安装 c option.php zblogphp教程 第1张

本文来说明下这个问题的原因和解决办法。

问题产生的原因:

c_option.php是zblog的数据库配置文件,当安装完成的时候程序会自动创建这个文件。如果你的主机权限不足,那么程序就创建不了这个文件,就会出现这个提示了。

所以这个问题的原因就是你的主机权限不够造成的。

问题的解决办法:

第一种:可以按照错误页面的提示,直接现在本地创建一个“c_option.php”文件,然后打开这个文件,把下面的代码复制粘贴到文件里面然后保存。最后上传到“根目录/zb_users/”文件夹里面即可。

PS:此方法治标不治本,你在后续的使用zblog的过程中还是会遇到因为权限不足导致的各种问题的。所以强烈推荐下面的方法。


第二种:将你的主机权限设置为“777”!

这种方法说起来简单,但是很多小白用户根本不知道从何下手…

因为每个人主机的环境都是不一样的,有的是windows+iis;有的是linux+Apache;有的是Linux+nginx;每一种环境下的设置方法是不一样的。所以请先确定你的环境是哪一种,然后用“环境名称”+“权限设置”为关键词去百度搜索下即可找到对应教程。

关于安装zblog提示“创建c_option.php失败”的原因和解决办法的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年11月18日 下午9:10
下一篇 2021年12月11日 下午9:07

相关推荐

  • wordpress子主题怎么添加

    WordPress子主题简介和原理 WordPress提供了子主题功能,让我们可以通过使用子主题进行修改WordPress主题,而不需要直接修改源码,而出现无法更新的内容。子主题需要有一个父级主题存在才能启用,根据WordPress主题的主要文件,子主题存在,WordPress则会自动使用子主题的文件,而放弃使用父主题。 这样,我们先要修改父级主题的哪一个文…

    2023年1月4日
    187
  • DZ论坛UCenter后台通信失败彻底解决方法(亲测有效)

    前面在论坛分享过discuz论坛更换目录后出现头像无法显示/ucenter无法进入,只是简单地讲了在更换子目录之后怎么重新设置参数,使得头像正常显示。 但是今天在迁移一个新的站点的时候发现ucenter彻底无法进入,直接是空白显示,如图。 另外全站会员都没法加载头像,图片显示失败。 这时候我考虑到是UCenter的链接是有问题的,但是我的uc_server文…

    2024年7月31日 • 建站知识
    347
  • 如何设置自动化更新网站底部当前年份?

    相信很多站长都比较苦恼,新的一年过去了,底部时间还停留在去年,那如何设置自动化更新网站底部当前年份呢?这里站长可乐教你一招。 网上大部分教程都会给你PHP代码去设置年份: 代码语言:javascript 复制 <?php echo date(‘Y’); ?> 事实上测试后,有可能并不能获取到当前年份,那应该怎么做呢? 代码语言:javascrip…

    2024年7月31日
    218
  • 说说如何抢先注册一个快过期的域名

    小编最近看上了一个域名,打算抢注,所以就提前做了功课,学习了怎么抢注一个快过期的域名,下面来具体说说! 1. 查看具体删除时间(重要点): 某域名过期 / 删除时间查询: 域名删除时间查询 最近可抢注域名查询 (国际): Pool.com : Pending Delete List 最近可抢注域名查询 (国内): 易名:过期域名预订列表 2. 预订抢注。 国…

    2021年9月11日
    503
  • 宝塔面板mysql进程守护shell脚本(数据库关闭后自动重启)

    我们使用宝塔面板搭建网站时,Mysql数据库有时会意外停止,这时候我们只能登录服务器进行手动重启Mysql。那么怎么设置监控Mysql的运行情况,当数据库进程停止时,自动重启Mysql数据库呢?其实我们可以通过添加计划任务(Shell脚本)的方式来实现。具体操作方法如下: 登陆宝塔面板后台 – 计划任务。任务类型:Shell脚本 任务名称:Mysql进程守护…

    2024年6月21日
    366