使用宝塔面板Shell脚本设置定时重启MySQL服务

服务器最近用宝塔数据库服务发现偶尔会长时间有很多占用内存的情况,配置也不是很高,只能定时重启一下MySQL服务了。给大家分享一下我的方法,挺简单的。

简单介绍

首先重启MySQL命令是 service mysqld restart,知道了就简单了,只要在计划任务加上shell脚本就好。

操作方法

1、打开计划任务界面,提交下图内容,然后在添加任务即可。

2、查看编辑情况,已设定每3时30分重启一次数据库。

使用宝塔面板Shell脚本设置定时重启MySQL服务

关于使用宝塔面板Shell脚本设置定时重启MySQL服务的相关内容;如有侵权,请联系老文删除。

赞 (0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2022年3月26日 上午1:04
下一篇 2022年4月3日 下午2:12

相关推荐

  • 网站错误提示“Error establishing a Redis connection”怎么办?

    WordPress建站使用缓存软件之后,经常会出现“Error establishing a Redis connection”的提示,如图: 去宝塔面板查看后发现,是因为MongoDB或者Redis插件被关闭,你需要手动重启插件才行。 我也没找到具体原因,想着应该是数据过大(70w条帖子),也有可能是我的设置有问题或者wp程序自身对大数据的处理不够好,所以…

    2024年7月31日
    599
  • 宝塔linux面板命令大全(最全宝塔linux面板命令)

    宝塔linux面板命令大全 安装宝塔 CentOS安装脚本 yum install -y wget && wget -O install.sh http://download.bt.cn/install/install_6.0.sh && sh install.sh Ubuntu/Deepin安装脚本 wget -O inst…

    2024年10月3日
    685
  • zblog提示“权限不足,请联系网站管理员!”的解决办法

    zblog用户在发布文章的时候会提示“权限不足,请联系网站管理员!”,出现这个提示的原因是因为使用了唐朝的“百搭会员中心”插件,而这个插件有一个bug一直没用更新导致的。 下面来说下使用了百搭会员插件后怎么设置普通用户如何发布文章。 首先你要去应用中心下载“zblog角色分配器”这个插件,设置普通用户也有文章发布权限。 然后发现即使开启了普通用户的文章发布权…

    2021年11月18日
    685
  • 数据库MySQL服务状态经常崩溃停止,一个自动化命令就可以解决

    我们建站的时候经常会碰到数据库崩溃停止的情况,可以使用 Shell 脚本来检测 MySQL 服务状态并在需要时重启它。以下是一个简单的 Shell 脚本示例,它会检查 MySQL 服务是否运行,如果服务停止,脚本将尝试重启服务。   通用方案 编写脚本:创建一个脚本文件,例如 restart_mysql.sh,并编写以下内容: 代码语言:bash …

    2024年7月31日
    362
  • 大更新全新UI:WordPress DUX主题更新至v8.0

    DUX作者又一次在星期一更新了主题。本次更新的为wordpress DUX主题v8.0。主要是WP更新6.0后一些微调功能。有需要的小伙伴可以去下载了。 更新日志: v8.0 2022-10-31 全新:全站UI重做,前端加载速度提升2倍 全新:全站图标重构,各种图标更加直观、细节更好 全新:一键换色功能重写,全新提供的14种优质配色可选 新增:夜间模式,包…

    2022年11月7日
    331